User Tools

Site Tools


dev:compiler_support

Differences

This shows you the differences between two versions of the page.

Link to this comparison view

Both sides previous revision Previous revision
Next revision
Previous revision
dev:compiler_support [2018/08/03 08:56]
alazzaro
dev:compiler_support [2019/03/05 16:59] (current)
alazzaro
Line 1: Line 1:
-While CP2K adheres to the Fortran ​2003 standard, not all compilers (or compiler versions) are able to build CP2K correctly.+While CP2K adheres to the Fortran ​2008 standard, not all compilers (or compiler versions) are able to build CP2K correctly.
 GCC is the most tested compiler. We test some Intel Compiler versions. All other compilers are only used for testing and they are not fully supported, i.e. they can be used with some restrictions. For more details see the CP2K [[https://​dashboard.cp2k.org/​|dashboard]]. For all other compilers and compiler versions not listed in the table, we suggest testing them by yourself by using the [[https://​www.cp2k.org/​dev:​regtesting|regression tests]]. GCC is the most tested compiler. We test some Intel Compiler versions. All other compilers are only used for testing and they are not fully supported, i.e. they can be used with some restrictions. For more details see the CP2K [[https://​dashboard.cp2k.org/​|dashboard]]. For all other compilers and compiler versions not listed in the table, we suggest testing them by yourself by using the [[https://​www.cp2k.org/​dev:​regtesting|regression tests]].
 The table below reports the status of compiling and testing __CP2K trunk version__, as reported by the dashboard.  ​ The table below reports the status of compiling and testing __CP2K trunk version__, as reported by the dashboard.  ​
  
 ^ Compiler ^ Versions ^ Systems ^ Support ^ Known Issues ^ Last check ^ ^ Compiler ^ Versions ^ Systems ^ Support ^ Known Issues ^ Last check ^
 +| GCC | < 4.6 | any | @yellow: UNSUPPORTED | Fails with ''​Pointer bounds remapping not yet implemented.''​ | 04/03/2019 |
 | GCC | ≥ 4.6.4 and ≤ 4.9.1 | x86_64 | @green: OK | None | 01/06/2018 | | GCC | ≥ 4.6.4 and ≤ 4.9.1 | x86_64 | @green: OK | None | 01/06/2018 |
 | GCC | ≥ 4.9.2 and ≤ 7.3 | x86_64 | @green: OK | None | Active | | GCC | ≥ 4.9.2 and ≤ 7.3 | x86_64 | @green: OK | None | Active |
 | GCC | 8.2 | x86_64 | @green: OK | None | Active | | GCC | 8.2 | x86_64 | @green: OK | None | Active |
 | Intel | ≤ 16.0.4 | X86_64 | @red: Doesn'​t compile | Failing compilation in dbcsr | 01/06/2018 | | Intel | ≤ 16.0.4 | X86_64 | @red: Doesn'​t compile | Failing compilation in dbcsr | 01/06/2018 |
-| Intel | 17.0.1 | X86_64 | @yellow: Partial | MPI parallelization broken (due to MKL) | Active ​|+| Intel | 17.0.1 | X86_64 | @yellow: Partial | MPI parallelization broken (due to MKL) | 15/​08/​2018 ​|
 | Intel | 17.0.4 | X86_64 | @green: OK | None | Active | | Intel | 17.0.4 | X86_64 | @green: OK | None | Active |
 | Intel | 18.0.0, 18.0.1 | X86_64 | @red: Broken | Fails at runtime | 01/07/2018 | | Intel | 18.0.0, 18.0.1 | X86_64 | @red: Broken | Fails at runtime | 01/07/2018 |
-| Intel | 18.0.3 | X86_64 | @green: OK | None | Active | +| Intel | 18.0.3, 18.0.5 ​| X86_64 | @green: OK | None | Active | 
-| PGI   | ≤ 18.5        ​| X86_64 | @red: Doesn'​t compile ​Failing compilation in dbcsr 15/07/2018 | +| PGI   | ≤ 18.10 | X86_64 | @red: BROKEN ​Fails with ICE or ''​PGF90-S-0091-Constant expression of wrong data type (dbcsr_types.F90:​ 494)''​ (ticket open @ PGI) 27/09/2018 | 
-| [[https://​github.com/​flang-compiler/​flang|flang]] | | x86_64 | @red: Horribly broken ​| [[https://​github.com/​flang-compiler/​flang/​issues/​239|#​239]],​ [[https://​github.com/​flang-compiler/​flang/​issues/​424|#​424]] | 01/06/2018 |+| [[https://​github.com/​flang-compiler/​flang|flang]] | | x86_64 | @red: BROKEN ​| [[https://​github.com/​flang-compiler/​flang/​issues/​239|#​239]],​ [[https://​github.com/​flang-compiler/​flang/​issues/​424|#​424]] | 01/06/2018 |
 | Cray compiler CCE | 8.6.1, 8.6.2, 8.6.5 | x86_64 | @red: Broken | Numerical instabilities,​ threading broken | 01/06/2018 | | Cray compiler CCE | 8.6.1, 8.6.2, 8.6.5 | x86_64 | @red: Broken | Numerical instabilities,​ threading broken | 01/06/2018 |
-| Cray compiler CCE | 8.7.| x86_64 | @green: OK | None (only POPT tested) | Active |+| Cray compiler CCE | 8.7.0, 8.7.1, 8.7.2, 8.7.3 | x86_64 | @green: OK | None (only POPT tested) | 01/09/2018 | 
 +| Cray compiler CCE | 8.7.4, 8.7.5 | x86_64 | @red: Doesn'​t compile | Failing compilation | 01/11/2018 | 
 +| Cray compiler CCE | 8.7.6, 8.7.7, 8.7.8 | x86_64 | @green: OK | None (only POPT tested)| 05/03/2019 | 
 +| Cray compiler CCE | 8.7.9 | x86_64 | @green: OK | None (only POPT tested)| Active |
 | IBM XL Fortran | 14.01 | IBM/​BlueGene Q | @green: OK | None (only POPT tested)| 01/07/2018 | | IBM XL Fortran | 14.01 | IBM/​BlueGene Q | @green: OK | None (only POPT tested)| 01/07/2018 |
dev/compiler_support.1533286585.txt.gz · Last modified: 2018/08/03 08:56 by alazzaro